• 華為實驗跨交換機相同VLAN之間通信

    計算機網絡通信技術分享 2021-09-11 14:54:49

    ? ? ? 上文和大家分享的主要是cisco體系的跨交換機的相同VLAN間的通信實現,今天采用華為體系和大家分享一下:

    ? ? ?華為產品對接口設定了access trunk hybrid,新增加的hybrid接口特性靈活控制了二層端口802.1Q即VLAN標簽TAG的有無,小編深切體會到華為hybrid可以靈活控制標簽的有無,客服了cisco體系的一些弊端,組網設計更加靈活。

    ? ? ? hybrid端口可以控制數據帶哪些標簽通過,同時哪些數據去掉標簽后通過,當收到的數據是不帶標簽的時候就會打上PVID規定的標簽,對于不允許通過的帶標簽數據可以禁止通過。同時也可以規定哪些VLAN標簽是去標簽后轉發的。

    ? ? 利用Hybrid的這些特性,可以組合出一下四種相同VLAN間通信方案:

    方案1:三層設備采用trunk互聯,客戶端口采用access互聯

    配置腳本:

    <Huawei>system-view

    [Huawei]sysname SwichA

    [SwichA]vlan batch 2 3

    Info: This operation may take a few seconds. Please wait for a moment...done.

    [SwichA]interface GigabitEthernet ?0/0/1

    [SwichA-GigabitEthernet0/0/1]port link-type access

    [SwichA-GigabitEthernet0/0/1]port default ?vlan 2

    [SwichA-GigabitEthernet0/0/1]quit

    [SwichA]interface GigabitEthernet ?0/0/2

    [SwichA-GigabitEthernet0/0/2]port link-type access

    [SwichA-GigabitEthernet0/0/2]port default vlan 3

    [SwichA-GigabitEthernet0/0/2]quit




    <Huawei>

    <Huawei>system-view

    [Huawei]sysname SwitchB

    [SwitchB]vlan batch 2 3

    [SwitchB]interface GigabitEthernet 0/0/1

    [SwitchB-GigabitEthernet0/0/1]port link-type access

    [SwitchB-GigabitEthernet0/0/1]port default vlan 2

    [SwitchB]interface GigabitEthernet 0/0/2

    [SwitchB-GigabitEthernet0/0/2]port link-type access

    [SwitchB-GigabitEthernet0/0/2]port default vlan 3

    [SwitchB-GigabitEthernet0/0/2]quit ?

    [SwitchB]return

    <SwitchB>


    三層設備互聯:

    [SwitchA]interface GigabitEthernet 0/0/3

    [SwitchA-GigabitEthernet0/0/3]port link-type trunk

    [SwitchA-GigabitEthernet0/0/3]port trunk allow-pass vlan 2 to 3




    [SwitchB]interface GigabitEthernet 0/0/3

    [SwitchB-GigabitEthernet0/0/3]port link-type trunk

    [SwitchB-GigabitEthernet0/0/3]port trunk allow-pass vlan 2 to 3



    方案二:三層設備互聯采用hybrid端口,客戶端采用access端口

    客戶端口同上:

    三層設備互聯端口配置:

    [SwitchA]

    [SwitchA]interface GigabitEthernet 0/0/4

    [SwitchA-GigabitEthernet0/0/4]port link-type hybrid

    [SwitchA-GigabitEthernet0/0/4]port hybrid tagged vlan 2 to 3

    [SwitchA-GigabitEthernet0/0/4]quit

    [SwitchA]

    注意:這里是允許帶有VLAN2和VLAN3標簽的數據幀帶標簽tagged通過hybrid端口


    [SwitchB]

    [SwitchB]interface GigabitEthernet 0/0/4

    [SwitchB-GigabitEthernet0/0/4]port link-type hybrid

    [SwitchB-GigabitEthernet0/0/4]port hybrid tagged vlan 2 to 3

    [SwitchB-GigabitEthernet0/0/4]quit

    [SwitchB]


    方案三:三層設備trunk互聯,客戶端采用Hybrid端口

    [SwichA]interface GigabitEthernet 0/0/24

    [SwichA-GigabitEthernet0/0/24]port link-type hybrid

    [SwichA-GigabitEthernet0/0/24]port hybrid untagged vlan 2

    [SwichA-GigabitEthernet0/0/24]port hybrid pvid vlan 2

    [SwichA-GigabitEthernet0/0/24]quit

    [SwichA] ?

    [SwichA]interface GigabitEthernet 0/0/23 ?

    [SwichA-GigabitEthernet0/0/23]port link-type hybrid

    [SwichA-GigabitEthernet0/0/23]port hybrid untagged vlan 3

    [SwichA-GigabitEthernet0/0/23]port hybrid pvid vlan 3

    [SwichA-GigabitEthernet0/0/23]quit

    [SwichA]

    注意:連接客戶端的接口為hybrid,電腦發包是不帶VLAN幀標簽的,這里允許無標簽數據加入VLAN3,然后打上PVID=vlan3的幀標簽即TAG


    [SwichB]interface GigabitEthernet 0/0/24

    [SwichB-GigabitEthernet0/0/24]port link-type hybrid

    [SwichB-GigabitEthernet0/0/24]port hybrid untagged vlan 2

    [SwichB-GigabitEthernet0/0/24]port hybrid pvid vlan 2

    [SwichB-GigabitEthernet0/0/24]quit

    [SwichB] ?

    [SwichB]interface GigabitEthernet 0/0/23 ?

    [SwichB-GigabitEthernet0/0/23]port link-type hybrid

    [SwichB-GigabitEthernet0/0/23]port hybrid untagged vlan 3

    [SwichB-GigabitEthernet0/0/23]port hybrid pvid vlan 3

    [SwichB-GigabitEthernet0/0/23]quit

    [SwichB]


    [SwitchA]interface GigabitEthernet 0/0/3

    [SwitchA-GigabitEthernet0/0/3]port link-type trunk

    [SwitchA-GigabitEthernet0/0/3]port trunk allow-pass vlan 2 to 3


    [SwitchB]interface GigabitEthernet 0/0/3

    [SwitchB-GigabitEthernet0/0/3]port link-type trunk

    [SwitchB-GigabitEthernet0/0/3]port trunk allow-pass vlan 2 to 3


    方案四:三層設備互聯與客戶端接口全部采用Hybrid端口

    [SwichA]interface GigabitEthernet 0/0/24

    [SwichA-GigabitEthernet0/0/24]port link-type hybrid

    [SwichA-GigabitEthernet0/0/24]port hybrid untagged vlan 2

    [SwichA-GigabitEthernet0/0/24]port hybrid pvid vlan 2

    [SwichA-GigabitEthernet0/0/24]quit

    [SwichA] ?

    [SwichA]interface GigabitEthernet 0/0/23 ?

    [SwichA-GigabitEthernet0/0/23]port link-type hybrid

    [SwichA-GigabitEthernet0/0/23]port hybrid untagged vlan 3

    [SwichA-GigabitEthernet0/0/23]port hybrid pvid vlan 3

    [SwichA-GigabitEthernet0/0/23]quit


    [SwichB]

    [SwichB]interface GigabitEthernet 0/0/24

    [SwichB-GigabitEthernet0/0/24]port link-type hybrid

    [SwichB-GigabitEthernet0/0/24]port hybrid untagged vlan 2

    [SwichB-GigabitEthernet0/0/24]port hybrid pvid vlan 2

    [SwichB-GigabitEthernet0/0/24]quit

    [SwichB] ?

    [SwichB]interface GigabitEthernet 0/0/23 ?

    [SwichB-GigabitEthernet0/0/23]port link-type hybrid

    [SwichB-GigabitEthernet0/0/23]port hybrid untagged vlan 3

    [SwichB-GigabitEthernet0/0/23]port hybrid pvid vlan 3

    [SwichB-GigabitEthernet0/0/23]quit

    [SwichB]



    [SwitchA]

    [SwitchA]interface GigabitEthernet 0/0/4

    [SwitchA-GigabitEthernet0/0/4]port link-type hybrid

    [SwitchA-GigabitEthernet0/0/4]port hybrid tagged vlan 2 to 3

    [SwitchA-GigabitEthernet0/0/4]quit

    [SwitchA]


    [SwitchB]

    [SwitchB]interface GigabitEthernet 0/0/4

    [SwitchB-GigabitEthernet0/0/4]port link-type hybrid

    [SwitchB-GigabitEthernet0/0/4]port hybrid tagged vlan 2 to 3

    [SwitchB-GigabitEthernet0/0/4]quit

    [SwitchB]

    如果你對這些比較感興趣,就動手試一試,光看是沒有用的?。?!

    ? ?下邊分享幾張華為關于hybrid接口的膠片(access 與trunk接口就不再區分了,與cisco是一樣的)

    ?

    ?

    DA: Destination address;

    SA: Source Address

    TAG:VLAN TAG

    TPID:Tag Protocol Identifier,2字節,固定取值,0x8100,是IEEE定義的新類型,表明這是一個攜帶802.1Q標簽的幀。

    TCI:Tag Control Information,2字節。幀的控制信息,詳細說明如下:

    Priority:3比特,表示以太網幀的優先級。一共有8種優先級,0-7,用于提供有差別的轉發服務。

    CFI:Canonical Format Indicator,1比特。用于令牌環/源路由FDDI介質訪問中指示地址信息的比特次序信息,即先傳送的是低比特位還是高比特位。

    VLAN Identified:VLAN ID,12比特,取值從0到4095。(cisco用戶可見0-1005)

    ? ???Hybrid端口可以靈活的控制VLAN標簽的移除情況。例如上圖如果待轉發的幀中的VLAN ID是100 101,則按照trunk端口的轉發模式轉發;如果是10 11 12,則移除標簽后再轉發,此時會被打上本征PVID VLAN標簽。

    ? ? ? ?Hybrid端口和Trunk端口的不同之處在于Hybrid端口可以允許多個VLAN的報文發送時不打標簽(cisco的本征VLAN),而Trunk端口只允許缺省VLAN的報文發送時不打標簽。

    ? ? ? ?Access端口發往其他設備的報文,都是untagged frame,而trunk端口僅在一種特定情況下才能發出untagged frame,其它情況發出的都是tagged frame。某些應用中,可能希望能夠靈活的控制VLAN標簽的移除。例如,在本交換機的上行設備不支持VLAN的情況下,希望實現各個用戶端口相互隔離。

    Hybrid端口可以靈活的控制VLAN標簽的移除情況。例如如果待轉發的幀中的VLAN ID是3,則按照trunk端口的轉發模式轉發;如果是4,則移除標簽4后再轉發。這就是Hybrid端口存在的原因!

    文檔寫作能力有限,希望大家能夠理解!

    ? ?Liketdlte?讓興趣成為生存技能

    Copyright ? 華為手機價格交流組@2017